kvm运行提示: Guset is not running…

1、先卸载qemu-kvm

# yum –y remove qemu-kvm

# rpm -e qemu (需要卸载依赖包后再原路返回依次删除)

源码地址:http://wiki.qemu.org/Download

2、下载源码

# mkdir /iso

# cd /iso

# wget http://wiki.qemu-project.org/download/qemu-2.8.0-rc0.tar.bz2

3、安装依赖包

yum -y install gcc gcc-c++ automake libtool zlib-devel glib2-devel bzip2-devel libuuid-devel spice-protocol spice-server-devel usbredir-devel libaio-devel bzip2-devel zlib-devel bzip2-devel  zlib-devel

4、编译安装

tar xf qemu-2.8.0.tar.bz2

cd qemu-2.8.0

./configure –enable-usb-redir –enable-libusb –enable-spice –enable-kvm –enable-bzip2 –prefix=/usr/local/qemu –enable-linux-aio –enable-system

make && make install

5、编译完成之后 做链接

 ln -s /usr/local/qemu/bin/qemu-system-x86_64 /usr/bin/qemu-kvm

 ln -s /usr/local/qemu/bin/qemu-system-x86_64 /usr/libexec/qemu-kvm

 ln -s /usr/local/qemu/bin/qemu-img /usr/bin/qemu-img

6、查看当前qemu版本,可以看到当前版本为2.8

    qemu-img  --version 

    qemu-kvm --version



    # rpm -q qemu-img

    # rpm -q qemu-kvm

7、如果提示没有安装qemu-kvm可安装:

#  yum install qemu-kvm libvirt virt-install bridge-utils -y  

8、编译过程遇到的错误

cd /home/src/qemu-2.8.0/pixman; autoreconf -v --install)/bin/sh: autoreconf: command not found

make: *** [/home/src/qemu-2.8.0/pixman/configure] Error 127

9、解决方法: yum –y install automake

configure.ac:75: error: possibly undefined macro: AC_PROG_LIBTOOL
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1

10、解决方法 yum –y install libtool

原文链接:https://blog.csdn.net/sinat_40356718/article/details/78734216

文档更新时间: 2020-05-03 11:33   作者:月影鹏鹏